iCollege Partial Outage
Incident Report for iCollege Status
Resolved
This incident has been resolved.
Posted Oct 04, 2021 - 16:20 SAST
Investigating
We are currently investigating this issue.
Posted Oct 04, 2021 - 16:03 SAST
This incident affected: iCollege Web.